Wednesday, July 14, 2021

MediaWiki: Exposure of Resource to Wrong Sphere (CVE-2021-35197)

Description
In MediaWiki before 1.31.15, 1.32.x through 1.35.x before 1.35.3, and 1.36.x before 1.36.1, bots have certain unintended API access. When a bot account has a "sitewide block" applied, it is able to still "purge" pages through the MediaWiki Action API (which a "sitewide block" should have prevented).
Solution(s)
  • mediawiki-upgrade-1_31_15
  • mediawiki-upgrade-1_35_3
  • mediawiki-upgrade-1_36_1


  • References
  • https://attackerkb.com/topics/cve-2021-35197
  • CVE - 2021-35197
  • https://lists.wikimedia.org/hyperkitty/list/[email protected]/thread/YR3X4L2CPSEJVSY543AWEO65TD6APXHP/
  • https://phabricator.wikimedia.org/T280226




  •  

    Copyright © 2020 Cyber Details - Vulnerability Database™

    Thanks for everything Templateism - You should have written the code a little more complicated