Wednesday, February 17, 2021

Red Hat: CVE-2021-20188: Moderate: container-tools:rhel8 security, bug fix, and enhancement update (RHSA-2020:3053)

Description
A flaw was found in podman before 1.7.0. File permissions for non-root users running in a privileged container are not correctly checked. This flaw can be abused by a low-privileged user inside the container to access any other file in the container, even if owned by the root user inside the container. It does not allow to directly escape the container, though being a privileged container means that a lot of security features are disabled when running the container. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.
Solution(s)
  • redhat-upgrade-buildah
  • redhat-upgrade-buildah-debuginfo
  • redhat-upgrade-buildah-debugsource
  • redhat-upgrade-buildah-tests
  • redhat-upgrade-buildah-tests-debuginfo
  • redhat-upgrade-cockpit-podman
  • redhat-upgrade-conmon
  • redhat-upgrade-container-selinux
  • redhat-upgrade-containernetworking-plugins
  • redhat-upgrade-containernetworking-plugins-debuginfo
  • redhat-upgrade-containernetworking-plugins-debugsource
  • redhat-upgrade-containers-common
  • redhat-upgrade-crit
  • redhat-upgrade-criu
  • redhat-upgrade-criu-debuginfo
  • redhat-upgrade-criu-debugsource
  • redhat-upgrade-fuse-overlayfs
  • redhat-upgrade-fuse-overlayfs-debuginfo
  • redhat-upgrade-fuse-overlayfs-debugsource
  • redhat-upgrade-libslirp
  • redhat-upgrade-libslirp-debuginfo
  • redhat-upgrade-libslirp-debugsource
  • redhat-upgrade-libslirp-devel
  • redhat-upgrade-podman
  • redhat-upgrade-podman-debuginfo
  • redhat-upgrade-podman-debugsource
  • redhat-upgrade-podman-docker
  • redhat-upgrade-podman-remote
  • redhat-upgrade-podman-remote-debuginfo
  • redhat-upgrade-podman-tests
  • redhat-upgrade-python-podman-api
  • redhat-upgrade-python3-criu
  • redhat-upgrade-runc
  • redhat-upgrade-runc-debuginfo
  • redhat-upgrade-runc-debugsource
  • redhat-upgrade-skopeo
  • redhat-upgrade-skopeo-debuginfo
  • redhat-upgrade-skopeo-debugsource
  • redhat-upgrade-skopeo-tests
  • redhat-upgrade-slirp4netns
  • redhat-upgrade-slirp4netns-debuginfo
  • redhat-upgrade-slirp4netns-debugsource
  • redhat-upgrade-toolbox
  • redhat-upgrade-udica


  • References
  • CVE-2021-20188




  •  

    Copyright © 2020 Cyber Details - Vulnerability Database™

    Thanks for everything Templateism - You should have written the code a little more complicated