Wednesday, January 12, 2022

Ubuntu Security Notice USN-5219-1

=========================================================================
Ubuntu Security Notice USN-5219-1
January 11, 2022

linux, linux-aws, linux-aws-5.11, linux-azure, linux-azure-5.11,
linux-gcp, linux-gcp-5.11, linux-hwe-5.11, linux-kvm, linux-oem-5.10,
linux-oracle, linux-oracle-5.11, linux-raspi vulnerability
=========================================================================
A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 21.10
- Ubuntu 21.04
- Ubuntu 20.04 LTS

Summary:

The system could be made to crash or run programs as an administrator.

Software Description:
- linux: Linux kernel
- linux-aws: Linux kernel for Amazon Web Services (AWS) systems
- linux-azure: Linux kernel for Microsoft Azure Cloud systems
- linux-gcp: Linux kernel for Google Cloud Platform (GCP) systems
- linux-kvm: Linux kernel for cloud environments
- linux-oracle: Linux kernel for Oracle Cloud systems
- linux-raspi: Linux kernel for Raspberry Pi systems
- linux-aws-5.11: Linux kernel for Amazon Web Services (AWS) systems
- linux-azure-5.11: Linux kernel for Microsoft Azure cloud systems
- linux-gcp-5.11: Linux kernel for Google Cloud Platform (GCP) systems
- linux-hwe-5.11: Linux hardware enablement (HWE) kernel
- linux-oem-5.10: Linux kernel for OEM systems
- linux-oracle-5.11: Linux kernel for Oracle Cloud systems

Details:

It was discovered that the eBPF implementation in the Linux kernel did
not properly validate the memory size of certain ring buffer operation
arguments. A local attacker could use this to cause a denial of service
(system crash) or possibly execute arbitrary code.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 21.10:
linux-image-5.13.0-1008-kvm 5.13.0-1008.8
linux-image-5.13.0-1009-aws 5.13.0-1009.10
linux-image-5.13.0-1010-azure 5.13.0-1010.11
linux-image-5.13.0-1010-gcp 5.13.0-1010.12
linux-image-5.13.0-1013-oracle 5.13.0-1013.16
linux-image-5.13.0-1013-raspi 5.13.0-1013.15
linux-image-5.13.0-1013-raspi-nolpae 5.13.0-1013.15
linux-image-5.13.0-25-generic 5.13.0-25.26
linux-image-5.13.0-25-generic-64k 5.13.0-25.26
linux-image-5.13.0-25-generic-lpae 5.13.0-25.26
linux-image-5.13.0-25-lowlatency 5.13.0-25.26
linux-image-aws 5.13.0.1009.11
linux-image-azure 5.13.0.1010.11
linux-image-gcp 5.13.0.1010.10
linux-image-generic 5.13.0.25.36
linux-image-generic-64k 5.13.0.25.36
linux-image-generic-lpae 5.13.0.25.36
linux-image-gke 5.13.0.1010.10
linux-image-kvm 5.13.0.1008.8
linux-image-lowlatency 5.13.0.25.36
linux-image-oem-20.04 5.13.0.25.36
linux-image-oracle 5.13.0.1013.14
linux-image-raspi 5.13.0.1013.19
linux-image-raspi-nolpae 5.13.0.1013.19
linux-image-virtual 5.13.0.25.36

Ubuntu 21.04:
linux-image-5.11.0-1022-kvm 5.11.0-1022.24
linux-image-5.11.0-1025-aws 5.11.0-1025.27
linux-image-5.11.0-1025-azure 5.11.0-1025.27
linux-image-5.11.0-1025-oracle 5.11.0-1025.27
linux-image-5.11.0-1025-raspi 5.11.0-1025.27
linux-image-5.11.0-1025-raspi-nolpae 5.11.0-1025.27
linux-image-5.11.0-1026-gcp 5.11.0-1026.29
linux-image-5.11.0-46-generic 5.11.0-46.51
linux-image-5.11.0-46-generic-64k 5.11.0-46.51
linux-image-5.11.0-46-generic-lpae 5.11.0-46.51
linux-image-5.11.0-46-lowlatency 5.11.0-46.51
linux-image-aws 5.11.0.1025.25
linux-image-azure 5.11.0.1025.25
linux-image-gcp 5.11.0.1026.25
linux-image-generic 5.11.0.46.46
linux-image-generic-64k 5.11.0.46.46
linux-image-generic-lpae 5.11.0.46.46
linux-image-gke 5.11.0.1026.25
linux-image-kvm 5.11.0.1022.23
linux-image-lowlatency 5.11.0.46.46
linux-image-oem-20.04 5.11.0.46.46
linux-image-oracle 5.11.0.1025.25
linux-image-raspi 5.11.0.1025.23
linux-image-raspi-nolpae 5.11.0.1025.23
linux-image-virtual 5.11.0.46.46

Ubuntu 20.04 LTS:
linux-image-5.10.0-1055-oem 5.10.0-1055.58
linux-image-5.11.0-1025-aws 5.11.0-1025.27~20.04.1
linux-image-5.11.0-1025-azure 5.11.0-1025.27~20.04.1
linux-image-5.11.0-1025-oracle 5.11.0-1025.27~20.04.1
linux-image-5.11.0-1026-gcp 5.11.0-1026.29~20.04.1
linux-image-5.11.0-46-generic 5.11.0-46.51~20.04.1
linux-image-5.11.0-46-generic-64k 5.11.0-46.51~20.04.1
linux-image-5.11.0-46-generic-lpae 5.11.0-46.51~20.04.1
linux-image-5.11.0-46-lowlatency 5.11.0-46.51~20.04.1
linux-image-aws 5.11.0.1025.27~20.04.24
linux-image-azure 5.11.0.1025.27~20.04.24
linux-image-gcp 5.11.0.1026.29~20.04.25
linux-image-generic-64k-hwe-20.04 5.11.0.46.51~20.04.23
linux-image-generic-hwe-20.04 5.11.0.46.51~20.04.23
linux-image-generic-lpae-hwe-20.04 5.11.0.46.51~20.04.23
linux-image-lowlatency-hwe-20.04 5.11.0.46.51~20.04.23
linux-image-oem-20.04 5.10.0.1055.56
linux-image-oem-20.04b 5.10.0.1055.56
linux-image-oracle 5.11.0.1025.27~20.04.18
linux-image-virtual-hwe-20.04 5.11.0.46.51~20.04.23

After a standard system update you need to reboot your computer to make
all the necessary changes.

ATTENTION: Due to an unavoidable ABI change the kernel updates have
been given a new version number, which requires you to recompile and
reinstall all third party kernel modules you might have installed.
Unless you manually uninstalled the standard kernel metapackages
(e.g. linux-generic, linux-generic-lts-RELEASE, linux-virtual,
linux-powerpc), a standard system upgrade will automatically perform
this as well.

References:
https://ubuntu.com/security/notices/USN-5219-1
https://launchpad.net/bugs/1956585

Package Information:
https://launchpad.net/ubuntu/+source/linux/5.13.0-25.26
https://launchpad.net/ubuntu/+source/linux-aws/5.13.0-1009.10
https://launchpad.net/ubuntu/+source/linux-azure/5.13.0-1010.11
https://launchpad.net/ubuntu/+source/linux-gcp/5.13.0-1010.12
https://launchpad.net/ubuntu/+source/linux-kvm/5.13.0-1008.8
https://launchpad.net/ubuntu/+source/linux-oracle/5.13.0-1013.16
https://launchpad.net/ubuntu/+source/linux-raspi/5.13.0-1013.15
https://launchpad.net/ubuntu/+source/linux/5.11.0-46.51
https://launchpad.net/ubuntu/+source/linux-aws/5.11.0-1025.27
https://launchpad.net/ubuntu/+source/linux-azure/5.11.0-1025.27
https://launchpad.net/ubuntu/+source/linux-gcp/5.11.0-1026.29
https://launchpad.net/ubuntu/+source/linux-kvm/5.11.0-1022.24
https://launchpad.net/ubuntu/+source/linux-oracle/5.11.0-1025.27
https://launchpad.net/ubuntu/+source/linux-raspi/5.11.0-1025.27
https://launchpad.net/ubuntu/+source/linux-aws-5.11/5.11.0-1025.27~20.04.1
https://launchpad.net/ubuntu/+source/linux-azure-5.11/5.11.0-1025.27~20.04.1
https://launchpad.net/ubuntu/+source/linux-gcp-5.11/5.11.0-1026.29~20.04.1
https://launchpad.net/ubuntu/+source/linux-hwe-5.11/5.11.0-46.51~20.04.1
https://launchpad.net/ubuntu/+source/linux-oem-5.10/5.10.0-1055.58
https://launchpad.net/ubuntu/+source/linux-oracle-5.11/5.11.0-1025.27~20.04.1
 

Copyright © 2021 Vulnerability Database | Cyber Details™

thank you Templateism for the design - You should have written the code a little more complicated - Nothing Encrypted anymore