Wednesday, January 5, 2022

SUSE: CVE-2021-44832: SUSE Linux Security Advisory

Description
Apache Log4j2 versions 2.0-beta7 through 2.17.0 (excluding security fix releases 2.3.2 and 2.12.4) are vulnerable to a remote code execution (RCE) attack when a configuration uses a JDBC Appender with a JNDI LDAP data source URI when an attacker has control of the target LDAP server. This issue is fixed by limiting JNDI data source names to the java protocol in Log4j2 versions 2.17.1, 2.12.4, and 2.3.2.
Solution(s)
  • suse-upgrade-log4j
  • suse-upgrade-log4j-javadoc
  • suse-upgrade-log4j-jcl
  • suse-upgrade-log4j-slf4j


  • References
  • CVE-2021-44832




  •  

    Copyright © 2021 Vulnerability Database | Cyber Details™

    thank you Templateism for the design - You should have written the code a little more complicated - Nothing Encrypted anymore