Tuesday, January 18, 2022

Jenkins Advisory 2022-01-12: CVE-2022-23118:

Description
Jenkins Debian Package Builder Plugin 1.6.11 and earlier implements functionality that allows agents to invoke command-line `git` at an attacker-specified path on the controller, allowing attackers able to control agent processes to invoke arbitrary OS commands on the controller.
Solution(s)
  • jenkins-lts-upgrade-2_319_2
  • jenkins-upgrade-2_330


  • References
  • https://attackerkb.com/topics/cve-2022-23118
  • CVE - 2022-23118
  • https://jenkins.io/security/advisory/2022-01-12/




  •  

    Copyright © 2021 Vulnerability Database | Cyber Details™

    thank you Templateism for the design - You should have written the code a little more complicated - Nothing Encrypted anymore