Wednesday, January 19, 2022

Jenkins Advisory 2022-01-12: CVE-2022-23107:

Description
Jenkins Warnings Next Generation Plugin 9.10.2 and earlier does not restrict the name of a file when configuring custom ID, allowing attackers with Item/Configure permission to write and read specific files with a hard-coded suffix on the Jenkins controller file system.
Solution(s)
  • jenkins-lts-upgrade-2_319_2
  • jenkins-upgrade-2_330


  • References
  • https://attackerkb.com/topics/cve-2022-23107
  • CVE - 2022-23107
  • https://jenkins.io/security/advisory/2022-01-12/




  •  

    Copyright © 2021 Vulnerability Database | Cyber Details™

    thank you Templateism for the design - You should have written the code a little more complicated - Nothing Encrypted anymore