Wednesday, May 12, 2021

Ubuntu Security Notice USN-4942-1

==========================================================================
Ubuntu Security Notice USN-4942-1
May 10, 2021

firefox vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 21.04
- Ubuntu 20.10
- Ubuntu 20.04 LTS
- Ubuntu 18.04 LTS

Summary:

Firefox could be made to crash or run programs as your login if it
opened a malicious website.

Software Description:
- firefox: Mozilla Open Source web browser

Details:

A race condition was discovered in Web Render Components. If a user were
tricked into opening a specially crafted website, an attacker could
potentially exploit this to execute arbitrary code.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 21.04:
firefox 88.0.1+build1-0ubuntu0.21.04.2

Ubuntu 20.10:
firefox 88.0.1+build1-0ubuntu0.20.10.2

Ubuntu 20.04 LTS:
firefox 88.0.1+build1-0ubuntu0.20.04.2

Ubuntu 18.04 LTS:
firefox 88.0.1+build1-0ubuntu0.18.04.2

After a standard system update you need to restart Firefox to make
all the necessary changes.

References:
https://ubuntu.com/security/notices/USN-4942-1
CVE-2021-29952

Package Information:

https://launchpad.net/ubuntu/+source/firefox/88.0.1+build1-0ubuntu0.21.04.2

https://launchpad.net/ubuntu/+source/firefox/88.0.1+build1-0ubuntu0.20.10.2

https://launchpad.net/ubuntu/+source/firefox/88.0.1+build1-0ubuntu0.20.04.2

https://launchpad.net/ubuntu/+source/firefox/88.0.1+build1-0ubuntu0.18.04.2
 

Copyright © 2020 Cyber Details - Vulnerability Database™

Thanks for everything Templateism - You should have written the code a little more complicated