Sunday, May 2, 2021

Red Hat: CVE-2021-25215: Important: bind security update (Multiple Advisories)

Description
In BIND 9.0.0 -> 9.11.29, 9.12.0 -> 9.16.13, and versions BIND 9.9.3-S1 -> 9.11.29-S1 and 9.16.8-S1 -> 9.16.13-S1 of BIND Supported Preview Edition, as well as release versions 9.17.0 -> 9.17.11 of the BIND 9.17 development branch, when a vulnerable version of named receives a query for a record triggering the flaw described above, the named process will terminate due to a failed assertion check. The vulnerability affects all currently maintained BIND 9 branches (9.11, 9.11-S, 9.16, 9.16-S, 9.17) as well as all other versions of BIND 9.
Solution(s)
  • redhat-upgrade-bind
  • redhat-upgrade-bind-chroot
  • redhat-upgrade-bind-debuginfo
  • redhat-upgrade-bind-devel
  • redhat-upgrade-bind-export-devel
  • redhat-upgrade-bind-export-libs
  • redhat-upgrade-bind-libs
  • redhat-upgrade-bind-libs-lite
  • redhat-upgrade-bind-license
  • redhat-upgrade-bind-lite-devel
  • redhat-upgrade-bind-pkcs11
  • redhat-upgrade-bind-pkcs11-devel
  • redhat-upgrade-bind-pkcs11-libs
  • redhat-upgrade-bind-pkcs11-utils
  • redhat-upgrade-bind-sdb
  • redhat-upgrade-bind-sdb-chroot
  • redhat-upgrade-bind-utils


  • References
  • CVE-2021-25215




  •  

    Copyright © 2020 Cyber Details - Vulnerability Database™

    Thanks for everything Templateism - You should have written the code a little more complicated