Friday, May 7, 2021

MFSA2021-18 Firefox: Security Vulnerabilities fixed in Firefox ESR 78.10.1 (CVE-2021-29951)

Description
The Mozilla Maintenance Service granted SERVICE_START access to BUILTIN|Users which, in a domain network, grants normal remote users access to start or stop the service. This could be used to prevent the browser update service from operating (if an attacker spammed the 'Stop' command); but also exposed attack surface in the maintenance service.Note: This issue only affected Windows operating systems older than Win 10 build 1709. Other operating systems are unaffected.
Solution(s)
  • mozilla-firefox-esr-upgrade-78_10_1


  • References
  • https://attackerkb.com/topics/cve-2021-29951
  • CVE - 2021-29951
  • http://www.mozilla.org/security/announce/2021/mfsa2021-18.html




  •  

    Copyright © 2020 Cyber Details - Vulnerability Database™

    Thanks for everything Templateism - You should have written the code a little more complicated