Thursday, March 4, 2021

Ubuntu Security Notice USN-4757-1

==========================================================================
Ubuntu Security Notice USN-4757-1
March 03, 2021

wpa vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 20.10
- Ubuntu 20.04 LTS
- Ubuntu 18.04 LTS
- Ubuntu 16.04 LTS

Summary:

wpa_supplicant could be made to crash or run programs if it received
specially crafted network traffic.

Software Description:
- wpa: client support for WPA and WPA2

Details:

It was discovered that wpa_supplicant did not properly handle P2P
(Wi-Fi Direct) provision discovery requests in some situations. A
physically proximate attacker could use this to cause a denial of service
or possibly execute arbitrary code.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 20.10:
wpasupplicant 2:2.9-1ubuntu8.2

Ubuntu 20.04 LTS:
wpasupplicant 2:2.9-1ubuntu4.3

Ubuntu 18.04 LTS:
wpasupplicant 2:2.6-15ubuntu2.8

Ubuntu 16.04 LTS:
wpasupplicant 2.4-0ubuntu6.8

After a standard system update you need to reboot your computer to make
all the necessary changes.

References:
https://usn.ubuntu.com/4757-1
CVE-2021-27803

Package Information:
https://launchpad.net/ubuntu/+source/wpa/2:2.9-1ubuntu8.2
https://launchpad.net/ubuntu/+source/wpa/2:2.9-1ubuntu4.3
https://launchpad.net/ubuntu/+source/wpa/2:2.6-15ubuntu2.8
https://launchpad.net/ubuntu/+source/wpa/2.4-0ubuntu6.8
 

Copyright © 2020 Cyber Details - Vulnerability Database™

Thanks for everything Templateism - You should have written the code a little more complicated